Check Point Reference:CPAI-2012-304
Date Published: 10 Jul 2012
Severity: Critical
Last Updated:
Source: CVE-2012-0163
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Microsoft .NET Framework 1.0 SP3
    Microsoft .NET Framework 1.1 SP1
    Microsoft .NET Framework 2.0 Service Pack 2
    Microsoft .NET Framework 3.5.1
    Microsoft .NET Framework 4
    Vulnerability Description A heap buffer overflow vulnerability has been reported in Microsoft .NET framework.
    Update/Patch AvaliableApply patches from: MS12-025
    Vulnerability DetailsThe vulnerability is due to improper parameters validation by the .NET Framework when passing data to a function. A remote attacker can exploit this issue by enticing a target user to open a web-page that contains a specially crafted XAML browser application (XBAP). Successful exploitation of this vulnerability could allow an attacker to take complete control of an affected system.

    Protection Overview

    This protection will detect and block attempts to open a specially crafted web page.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Microsoft .NET Framework Parameter Validation Code Execution (MS12-025) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Web Client Enforcement Violation
    Attack Information: Microsoft .NET Framework Parameter Validation Code Execution (MS12-025)