Check Point Reference:CPAI-2012-1301
Date Published: 30 Dec 2012
Severity: Critical
Last Updated:
Source: CVE-2012-5677
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.5.502.110 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.251 and earlier versions for Linux
    Adobe Flash Player 11.1.115.27 and earlier versions for Android 4.x
    Adobe Flash Player 11.1.111.24 and earlier versions for Android 3.x and 2.x
    Adobe AIR 3.5.0.600 and earlier versions for Windows and Macintosh, SDK and Android
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player and AIR.
    Update/Patch AvaliableApply patches from: APSB12-27
    Vulnerability DetailsThe vulnerability is due to an error while handling specially crafted PCM files. A remote attacker can exploit this issue by enticing a victim to open a specially crafted PCM file. Successful exploitation would allow an attacker to execute arbitrary code on the target.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player PCM File Integer Overflow (APSB12-27) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Products Violation
    Attack Information: Adobe Flash Player PCM File Integer Overflow (APSB12-27)