Check Point Reference:CPAI-2012-612
Date Published: 14 Oct 2012
Severity: High
Last Updated:
Source: CVE-2009-1016
Protection Provided by:

Security Gateway
R75

Who is Vulnerable? Oracle BEA WebLogic Server 7.0.x through 7.0 SP7
Oracle BEA WebLogic Server 8.1.x through 8.0 SP6
Oracle BEA WebLogic Server 9.0
Oracle BEA WebLogic Server 9.1
Oracle BEA WebLogic Server 9.2.x through 9.2 MP3
Oracle BEA WebLogic Server 10.0.x through 10.0 MP1
Oracle BEA WebLogic Server 10.3
Vulnerability Description There exists a buffer overflow vulnerability in BEA WebLogic Server Plugins.
Vulnerability DetailsThe vulnerability is due to a boundary error while parsing SSL certificates. A remote unauthenticated attacker can exploit this vulnerability by sending a crafted certificate to the target host. In an attack case where code injection is successful, the behaviour of the target is entirely dependent on the intended function of the injected code. In an attack case where code injection is not successful, the affected process will terminate abnormally.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Oracle BEA WebLogic Server client Certificate Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:
Attack Name: SSL Protection Violation
Attack Information: Oracle BEA WebLogic Server client Certificate Buffer Overflow