Check Point Reference:CPAI-2012-1136
Date Published: 30 Dec 2012
Severity: Critical
Last Updated:
Source: CVE-2012-5270
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.4.402.278 and earlier versions for Windows
    Adobe Flash Player 11.4.402.265 and earlier versions for Macintosh
    Adobe Flash Player 11.2.202.238 and earlier versions for Linux
    Adobe Flash Player 11.1.115.17 and earlier versions for Android 4.x
    Adobe Flash Player 11.1.111.16 and earlier versions for Android 3.x and 2.x
    Adobe AIR 3.4.0.2540 and earlier versions for Windows and Macintosh
    Adobe AIR 3.4.0.2540 SDK (includes AIR for iOS) and earlier versions
    Adobe AIR 3.4.0.2540 and earlier versions for Android
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player.
    Update/Patch AvaliableApply patches from: APSB12-22
    Vulnerability DetailsThe vulnerability is due to an invalid memory read access. A remote attacker can exploit this issue by enticing a victim to open a specially crafted SWF file. Successful exploitation would allow an attacker to execute arbitrary code on the target.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Type Confusion Remote Code Execution (APSB12-22) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Products Violation
    Attack Information: Adobe Flash Player Type Confusion Remote Code Execution (APSB12-22)