Check Point Reference:CPAI-2013-092
Date Published: 7 Feb 2013
Severity: High
Last Updated:
Source: CVE-2013-0634
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.5.502.146 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.261 and earlier versions for Linux
    Adobe Flash Player 11.1.115.36 and earlier versions for Android 4.x
    Adobe Flash Player 11.1.111.31 and earlier versions for Android 3.x and 2.x
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player.
    Update/Patch AvaliableApply patches from: APSB13-04
    Vulnerability DetailsThe vulnerability is caused due to an improper buffer allocation by the flash player PCRE engine. A remote attacker can exploit this issue by enticing a target user to open a web-page that contains a specially crafted SWF file.

    Protection Overview

    This protection will detect and block attempts to open a specially crafted SWF files.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player ActionScript Code Heap Buffer Overflow (APSB13-04) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Flash Protection Violation
    Attack Information: Adobe Flash Player ActionScript Code Heap Buffer Overflow (APSB13-04)