Check Point Reference:CPAI-2014-1513
Date Published: 18 May 2014
Severity: Critical
Last Updated:4 May 2014
Source:
Protection Provided by:

Security Gateway
R77

  • R76
  • R75

  • Who is Vulnerable?
    Web browsers
    Vulnerability Description Known exploits could potentially bypass security products by using JavaScript obfuscation techniques. Since the exploits are obfuscated they may not be detected by IDS and IPS systems, thus allowing attackers to successfully attack target machines.

    Protection Overview

    This protection will detect and block attempts to bypass IPS using JavaScript obfuscation techniques.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the JavaScript Malicious Obfuscation Techniques - Ver2 protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Web Client Enforcement Violation.
    Attack Information:  JavaScript Malicious Obfuscation Techniques - Ver2