Check Point Reference:CPAI-2014-1517
Date Published: 18 May 2014
Severity: High
Last Updated:11 May 2014
Source:
Protection Provided by:

Security Gateway
R77

  • R76
  • R75

  • Who is Vulnerable? Nagios Enterprises Nagios Remote Plugin Executor 2.15 and prior
    Vulnerability Description A command injection vulnerability has been found in Nagios Remote Plugin Executor. The vulnerability is due to insufficient validation of user-provided parameters containing newline characters. A remote, unauthenticated attacker could exploit this vulnerability to execute arbitrary commands on the vulnerable machine with the privileges of the affected service.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Nagios Remote Plugin Executor Command Injection protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Web Server Enforcement Violation.
    Attack Information:  Nagios Remote Plugin Executor Command Injection