Check Point Reference:CPAI-2014-0031
Date Published: 9 Apr 2014
Severity: Critical
Last Updated:9 Apr 2014
Source: CVE-2009-1979
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable?
Vulnerability Description A buffer overflow vulnerability has been reported in the Oracle Database server. The vulnerability is due to an error in the Oracle Database server that fails to sufficiently validate the length field of the AUTH_SESSKEY parameter. A remote attacker could exploit this vulnerability by sending malicious packets to the target server. Successful exploitation of this vulnerability could allow a remote attacker to execute arbitrary code on the affected system.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Oracle Database Server AUTH_SESSKEY Stack Buffer Overflow - Ver2 protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Oracle Protection Violation.
Attack Information:  Oracle Database Server AUTH_SESSKEY Stack Buffer Overflow - Ver2