Check Point Reference:CPAI-2014-1333
Date Published: 9 Apr 2014
Severity: Critical
Last Updated:9 Apr 2014
Source:
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable?
Google Android prior to 4.2
Vulnerability Description A remote code execution vulnerability has been reported in Google Android prior to 4.2. The vulnerability is due to an error in the addJavascriptInterface method within the WebView class, commonly used in numerous mobile applications. A remote attacker can exploit this vulnerability by persuading a victim to view a specially crafted web content or by deploying a Man in the Middle attack.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Google Android addJavascriptInterface Remote Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Content Protection Violation.
Attack Information:  Google Android addJavascriptInterface Remote Code Execution