Check Point Reference:CPAI-2014-1617
Date Published: 9 Jun 2014
Severity: High
Last Updated:9 Jun 2014
Source: CVE-2014-0221
Protection Provided by:

Security Gateway

  • R76
  • R75
  • R71
  • R70

  • Who is Vulnerable? OpenSSL prior 0.9.8za, 1.0.0 before 1.0.0m and 1.0.1 before 1.0.1h
    Vulnerability Description A Denial of Service vulnerability has been reported in older versions of OpenSSL. The vulnerability is due to a DTLS recursion flaw. A remote attacker can exploit this vulnerability by sending an invalid DTLS handshake to an OpenSSL DTLS client.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the OpenSSL DTLS Hello Message Denial of Service protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  SSL Enforcement Violation.
    Attack Information:  OpenSSL DTLS Hello Message Denial of Service