Check Point Reference:CPAI-2014-1128
Date Published: 26 Mar 2014
Severity: Medium
Last Updated:26 Mar 2014
Source: CVE-2014-0980
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable? Poster Software PUBLISH-iT v3.6d
Vulnerability Description A stack buffer overflow vulnerability exists in Poster Software PUBLISH-iT. The vulnerability is due to insufficient validation on the length of entry names in a "styl" record when processing PUI files. A remote unauthenticated attacker can exploit this vulnerability by enticing a user to open a malicious PUI file. Successful exploitation could result in arbitrary code execution in the context of the currently logged in user.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Poster Software PUBLISH-iT PUI File Processing Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Web Client Enforcement Violation.
Attack Information:  Poster Software PUBLISH-iT PUI File Processing Buffer Overflow