Check Point Reference:CPAI-2014-0902
Date Published: 17 Feb 2014
Severity: High
Last Updated:
Source: CVE-2013-6447
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable? Red Hat JBoss Seam 2.3.1 and prior
Vulnerability Description An information disclosure vulnerability has been reported in Red Hat JBoss Seam Framework. The vulnerability is due to an incorrectly configured XML parser accepting XML eXternal Entities (XXE) from untrusted sources being used by the ExecutionHandler, PollHandler, and SubscriptionHandler classes within the JBoss Seam Framework's Remoting component. A remote unauthenticated attacker may exploit this vulnerability on a web application powered by the JBoss Seam Framework to disclose the contents of files via specially crafted XML documents.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Red Hat JBoss Seam Framework XXE Information Disclosure protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:
Attack Name: Application Servers Protection Violation
Attack Information: Red Hat JBoss Seam Framework XXE Information Disclosure