Home Page | Skip to Navigation | Skip to Content | Skip to Search | Skip to Footer

ElasticSearch search Remote Code Execution (CVE-2014-3120)

Subscribe

Check Point Reference: CPAI-2014-1629
Date Published:
Severity:
Last Updated:
Source: rapid7
Industry Reference(s): CVE-2014-3120
Protection Provided by: Security Gateway
  • R77
  • R76
  • R75
Who is Vulnerable?
ElasticSearch 1.1.1
Vulnerability Description
A remote command execution vulnerability has been found in ElasticSearch. The vulnerability is due to the search function in the REST API which does not require authentication and allows dynamic scripts execution. A remote attacker can exploit this weakness to execute arbitrary code via a specially crafted request.

Protection Overview
The protection will detect and block attempts to exploit this weakness

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

To configure the defense, select your product from the list below and follow the related protection steps.

Security Gateway R77 / R76 / R75 / R71 / R70

How Can I Protect My Network?

  1. In the IPS tab, click Protections and find the ElasticSearch search Remote Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

How Do I Know if My Network is Under Attack?
SmartView Tracker will log the following entries:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  ElasticSearch search Remote Code Execution