Check Point Reference:CPAI-2014-1148
Date Published: 18 May 2014
Severity: High
Last Updated:8 May 2014
Source: CVE-2013-5907
Protection Provided by:

Security Gateway
R77

  • R76
  • R75

  • Who is Vulnerable? Oracle Java Development Kit (JDK) 5 Update 55 and prior
    Oracle Java Development Kit (JDK) 6 Update 65 and prior
    Oracle Java Development Kit (JDK) 7 Update 45 and prior
    Oracle Java Runtime Environment (JRE) 5 Update 55 and prior
    Oracle Java Runtime Environment (JRE) 6 Update 65 and prior
    Oracle Java Runtime Environment (JRE) 7 Update 45 and prior
    Oracle JRockit R27.7.7
    Oracle JRockit R28.2.9
    Vulnerability Description A heap buffer overflow vulnerability exists in Oracle Java. The vulnerability is due to invalid processing of the ReqFeatureIndex entry in the GSUB table. A remote unauthenticated attacker can exploit this vulnerability by enticing a user to visit a webpage containing a maliciously crafted Java applet. Successful exploitation could result in arbitrary code execution in the context of the currently logged in user.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Oracle Java SE GSUB ReqFeatureIndex Buffer Overflow - ver 2 protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Oracle Protection Violation.
    Attack Information:  Oracle Java SE GSUB ReqFeatureIndex Buffer Overflow - ver 2