Check Point Reference:CPAI-2014-1545
Date Published: 28 May 2014
Severity: Critical
Last Updated:28 May 2014
Source: CVE-2014-0510
Protection Provided by:

Security Gateway
R77

  • R76
  • R75
  • R71
  • R70

  • Who is Vulnerable? Adobe Flash Player 13.0.0.206 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.356 and earlier versions for Linux
    Adobe AIR 13.0.0.83 SDK and earlier versions
    Adobe AIR 13.0.0.83 SDK & Compiler and earlier versions
    Vulnerability Description A memory corruption vulnerability has been reported in Adobe Flash Player. The vulnerability is due to an error in Adobe Flash Player while parsing a specially crafted SWF file. A remote attacker can exploit this issue by enticing a victim to open a specially crafted SWF file.
    Update/Patch AvaliableApply patches from: APSB14-14

    Protection Overview

    This protection will detect and block attempts to transfer malformed SWF files over HTTP.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Memory Corruption (APSB14-14: CVE-2014-0510) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Adobe Flash Protection Violation.
    Attack Information:  Adobe Flash Player Memory Corruption (APSB14-14: CVE-2014-0510)