Check Point Reference:CPAI-2014-1165
Date Published: 24 Mar 2014
Severity: High
Last Updated:24 Mar 2014
Source:
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable?
Web Servers
Vulnerability Description The XMLRPC Pingback function in WordPress can be used to force WordPress servers into sending HTTP requests to other servers. Remote attackers can leverage this function to conduct DDoS attacks by sending specially crafted HTTP requests to legitimate WordPress servers.

Protection Overview

This protection will detect and block multiple requests sent from WordPress servers over a short period of time.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the WordPress Pingback Distributed Denial of Service protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  WordPress Pingback Distributed Denial of Service