Check Point Reference:CPAI-2013-3758
Date Published: 14 Jan 2014
Severity: High
Last Updated:
Source: CVE-2013-5331
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.9.900.152 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.327 and earlier versions for Linux
    Adobe AIR 3.9.0.1210 and earlier versions for Windows and Macintosh
    Adobe AIR 3.9.0.1210 and earlier versions for Android
    Adobe AIR 3.9.0.1210 SDK and earlier versions
    Adobe AIR 3.9.0.1210 SDK & Compiler and earlier versions
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player. The vulnerability is due to a type confusion condition while handling a malformed SWF file. A remote attacker can exploit this issue by enticing a victim to open a specially crafted SWF file. Successful exploitation would allow an attacker to execute arbitrary code on the target.
    Update/Patch AvaliableApply patches from: APSB13-28

    Protection Overview

    This protection will detect and block the transferring of malicious SWF files.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player Type Confusion Arbitrary Code Execution (APSB13-28) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Reader Violation
    Attack Information: Adobe Flash Player Type Confusion Arbitrary Code Execution (APSB13-28)