Check Point Reference:CPAI-2014-1181
Date Published: 8 Apr 2014
Severity: High
Last Updated:30 Mar 2014
Source: CVE-2013-4547
Protection Provided by:

Security Gateway
R75 and above

Who is Vulnerable? nginx HTTP Server 1.5.x prior to 1.5.7
nginx HTTP Server 1.x prior 1.4.4
Vulnerability Description There exists a security bypass vulnerability in Nginx. The vulnerability is caused by improper handling of unescaped space characters within URIs. A remote attacker can exploit this vulnerability to bypass security restrictions in certain configurations.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

  1. In the IPS tab, click Protections and find the Nginx Request URI Verification Security Bypass protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  Nginx Request URI Verification Security Bypass