Check Point Reference:CPAI-2014-1574
Date Published: 27 May 2014
Severity: High
Last Updated:27 May 2014
Source: CVE-2014-0384
Protection Provided by:

Security Gateway
R77

  • R76
  • R75

  • Who is Vulnerable? Oracle MySQL 5.5.35 and earlier
    Oracle MySQL 5.6.15 and earlier
    Vulnerability Description A memory-corruption vulnerability has been reported in the Oracle MySQL Server. This vulnerability is due to an error in the XPath component when processing queries containing XML function calls. A remote, authenticated attacker can exploit this vulnerability by sending a malicious SQL request to target server.

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Oracle MySQL Server XPath Denial Of Service protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  MySQL Protection Violation.
    Attack Information:  Oracle MySQL Server XPath Denial Of Service