Check Point Reference:CPAI-2014-1735
Date Published: 3 Aug 2014
Severity: Critical
Last Updated:29 Jul 2014
Source: CVE-2014-4671
Protection Provided by:

Security Gateway
R77

  • R76
  • R75
  • R71
  • R70

  • Who is Vulnerable? Adobe Flash Player 14.0.0.125 and earlier versions for Windows and Macintosh
    Adobe Flash Player 11.2.202.378 and earlier versions for Linux
    Adobe AIR 14.0.0.110 SDK and earlier versions
    Adobe AIR 14.0.0.110 SDK & Compiler and earlier versions
    Adobe AIR 14.0.0.110 and earlier versions for Android
    Vulnerability Description A cross-site request forgery (CSRF) vulnerability has been reported in Adobe Flash Player. The vulnerability is due to an insufficient validation of data from JSONP callback APIs. A remote attacker can exploit this issue by enticing a victim to open a specially crafted SWF file.
    Update/Patch AvaliableApply patches from: APSB14-17

    Protection Overview

    This protection will detect and block attempts to exploit this vulnerability.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    1. In the IPS tab, click Protections and find the Adobe Flash Player JSONP Cross-Site Request Forgery (APSB14-17: CVE-2014-4671) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:

    Attack Name:  Adobe Products Violation.
    Attack Information:  Adobe Flash Player JSONP Cross-Site Request Forgery (APSB14-17: CVE-2014-4671)