Staying Safe in Times of Cyber Uncertainty
Check Point Advisories

GitLab Cross-site Scripting (CVE-2022-1190)

Check Point Reference: CPAI-2022-0330
Date Published: 11 Jul 2022
Severity: Medium
Last Updated: Monday 11 July, 2022
Source:
Industry Reference:CVE-2022-1190
Protection Provided by:

Security Gateway
R81, R80, R77, R75

Who is Vulnerable? GitLab Community and Enterprise editions from version 8.3 and prior to 14.7.7
GitLab Community and Enterprise editions from version 14.8 and prior to 14.8.5
GitLab Community and Enterprise editions from version 14.9 and prior to 14.9.2
Vulnerability Description A cross-site scripting vulnerability exists in GitLab. Successful exploitation of this vulnerability would allow remote attackers to inject arbitrary web script into the affected system.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R81 / R80 / R77 / R75

  1. In the IPS tab, click Protections and find the GitLab Cross-site Scripting (CVE-2022-1190) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation.
Attack Information:  GitLab Cross-site Scripting (CVE-2022-1190)

×
  Feedback
This website uses cookies for its functionality and for analytics and marketing purposes. By continuing to use this website, you agree to the use of cookies. For more information, please read our Cookies Notice.
OK