How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

LANDesk Management Suite Alert Service Stack Overflow (CVE-2007-1674)

Check Point Reference: CPAI-2007-070
Date Published: 16 May 2007
Severity: High
Last Updated: 20 Sep 2015
Source:
Industry Reference:CVE-2007-1674
Protection Provided by:

Security Gateway
R80, R77, R76, R75, R71, R70

Who is Vulnerable?
Vulnerability Description LANDesk Management Suite automates systems and security management tasks and proactively manages, updates and protects desktops, servers and mobile devices from a single console. A stack buffer overflow vulnerability has been discovered in LANDesk Management Suite. The vulnerability is due to a boundary error in the LANDesk Management Alert Service when processing specially crafted packets received on port 65535/UDP. Successful exploitation of this issue may allow execution of arbitrary code on the affected system.

Protection Overview

This protection will detect and block specially crafted packets sent via port 65535/UDP. The detect mode makes it possible to track unauthorized traffic without blocking it.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the LANDesk Management Suite Alert Service Stack Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  LANDesk Management Suite Enforcement.
Attack Information:  LANDesk Management Suite alert service stack overflow