Check Point Advisories

FLAC libFLAC Multiple Buffer Overflows (CVE-2007-4619)

Check Point Reference: CPAI-2007-136
Date Published: 22 Nov 2007
Severity: High
Last Updated: 27 Sep 2015
Source:
Industry Reference:CVE-2007-4619
Protection Provided by:

Security Gateway
R80, R77, R76, R75, R71, R70

Who is Vulnerable?
Vulnerability Description Free Lossless Audio Codec (FLAC) is a file format designed for audio data compression. LibFLAC is the FLAC project library embedded in various products.A buffer overflow vulnerability has been reported in the FLAC.A remote attacker can exploit this vulnerability via a specially crafted FLAC file.Successful exploitation of the vulnerability allows execution of arbitrary code on a vulnerable system.

Protection Overview

This protection will detect and block the transferring of malformed FLAC files over HTTP.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the FLAC libFLAC Multiple Buffer Overflows protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Content Protection Violation.
Attack Information:  FLAC libFLAC Multiple Buffer Overflows

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!