Check Point Advisories

Adobe Flash Player Insecure Library Loading (APSB12-03; CVE-2012-0756)

Check Point Reference: CPAI-2012-067
Date Published: 27 Feb 2012
Severity: Critical
Last Updated:
Source: CVE-2012-0756
Protection Provided by:

Security Gateway
R70

  • R71
  • R75

  • Who is Vulnerable? Adobe Flash Player 11.1.102.55 and earlier versions
    Vulnerability Description A remote code execution vulnerability has been reported in Adobe Flash Player.
    Vulnerability DetailsThe vulnerability is due to insecure library loading while handling certain files. A remote attacker could exploit this issue by enticing a user to open a legitimate file that will insecurely load a specially crafted DLL file located in the same network directory. Successful exploitation of this vulnerability could allow the attacker to take complete control of an affected system.

    Protection Overview

    This protection will detect and block the transferring of suspicious DLL files over CIFS.

    In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, Protection tab and select the version of your choice.

    Security Gateway R75 / R71 / R70

    1. In the IPS tab, click Protections and find the Adobe Flash Player Insecure Library Loading (APSB12-03) protection using the Search tool and Edit the protection's settings.
    2. Install policy on all modules.

    SmartView Tracker will log the following entries:
    Attack Name: Adobe Products Violation
    Attack Information: Adobe Flash Player insecure library loading (APSB12-03)

    This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO