Check Point Advisories

Oracle Warehouse Builder WB_OLAP_AW_REMOVE_SOLVE_ID SQL Injection (CVE-2011-0799)

Check Point Reference: CPAI-2012-038
Date Published: 31 Jan 2012
Severity: Critical
Last Updated:
Source: CVE-2011-0799
Protection Provided by:

Security Gateway
R75

Who is Vulnerable? Warehouse Builder 10.2.0.5
Vulnerability Description An SQL injection vulnerability has been reported in Oracle Warehouse Builder, a component of Oracle Database.
Vulnerability DetailsThe vulnerability is due to improper input validation in a certain procedure. A remote attacker with limited user privileges could exploit this vulnerability calling the affected procedure. Successful exploitation could lead to information disclosure and allow the attacker to execute arbitrary code on the affected system.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

Security Gateway R75 / R71 / R70

  1. In the IPS tab, click Protections, find the Oracle Warehouse Builder WB_OLAP_AW_REMOVE_SOLVE_ID SQL Injection protection and activate the protection.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:
Attack Name: Oracle Protection Violation
Attack Information: Oracle Warehouse Builder WB_OLAP_AW_REMOVE_SOLVE_ID SQL injection

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO