How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

Mozilla Firefox XPCOM Plugin Access Control (CVE-2005-0527)

Check Point Reference: CPAI-2005-207
Date Published: 30 Sep 2009
Severity: High
Last Updated: 3 Aug 2016
Source:
Industry Reference:CVE-2005-0527
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description Mozilla Firefox is a popular web-browser available for many platforms. Firefox implements a cross-platform component architecture called XPCOM (Cross-Platform Component Object Model) that allows for the development of modular software such as browser plug-ins. These objects can be invoked through JavaScript through a service called XPConnect.There exists a vulnerability in the way the XPCOM implementation in Mozilla and Mozilla Firefox performs security checks. The vulnerable XPCOM implementation does not properly enforce a reduced privilege security context to remote content loaded via certain plug-ins. A remote attacker can exploit this vulnerability to execute arbitrary code with the privileges of the target user by enticing the target user to visit a specially crafted web site.There is no change in behaviour on the target. The user believes that the product is functioning normally. In reality, the product is executing attacker-supplied scripting code. The behaviour of the target upon code execution is dependent on the nature of the malicious content. The crafted code executes with the privileges of Mozilla Firefox, which is typically running with the privileges of the currently logged in user.

Protection Overview

This protection detects attempts to exploit this vulnerability

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Mozilla Firefox XPCOM Plugin Access Control protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Web Client Enforcement Violation
Attack Information:  Mozilla Firefox XPCOM plugin access control