Check Point Advisories

Ipswitch WhatsUp Small Business Application Suite Directory Traversal (CVE-2005-1939)

Check Point Reference: CPAI-2005-323
Date Published: 1 Dec 2009
Severity: High
Last Updated: 4 Apr 2016
Source:
Industry Reference:CVE-2005-1939
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description The Ipswitch WhatsUp Small Business product is an application suite which provides monitoring and protection services for a small network. The program allows a network to be mapped, devices monitored, and failures to be detected.A directory traversal vulnerability exists in the Ipswitch Whatsup Small Business product. The flaw is caused by insufficient sanitization of HTTP requests. This vulnerability allows an unauthorized user to read arbitrary files on the target host.The target will not exhibit any unusual behaviour as a result of this attack. A successful attack will result in potentially sensitive information being disclosed to an unprivileged user. The content of arbitrary files, specified by the attacker in the request will be served in the HTTP response.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Ipswitch WhatsUp Small Business Application Suite Directory Traversal protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation
Attack Information:  Ipswitch Whatsup Small Business application suite directory traversal

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!