Check Point Advisories

MySQL MaxDB WebDBM Server Buffer Overflow (CVE-2006-4305)

Check Point Reference: CPAI-2006-241
Date Published: 10 Nov 2009
Severity: High
Last Updated: 18 Dec 2018
Source:
Industry Reference:CVE-2006-4305
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description MaxDB is an open source database application suite developed by MySQL AB that is available for various operating systems. The software bundles an HTTP server component, named Webtool, to provide a web-based application interface. Clients can connect to the Webtool with a web browser and access published applications. Unlike other more established application servers, there is little separation between the web application being hosted on the HTTP server and the HTTP server itself. Thus, the terms "HTTP server component" and "WebDBM" are interchangeable, as they share the same memory space. All communication between the client and server is performed over HTTP on port TCP/9999. A buffer overflow vulnerability exists in MySQL AB MaxDB. The vulnerability resides inside the WebDBM component and is due to insufficient boundary checks on the database name provided by the remote user. An unauthenticated remote attacker may exploit this vulnerability to inject and execute arbitrary code under the privileges of the Database WebDBM server. In a simple attack case aimed at creating a denial of service condition, the affected MaxDB WebDBM service will terminate. If the service is not configured to restart automatically, then the MaxDB WebDBM functionality will be unavailable until the service is restarted manually. In a more sophisticated attack scenario, where the malicious user is successful in injecting and executing code, the behaviour of the system is dependent on the nature the injected code. Any code injected into the vulnerable component would execute in the security context of the service process. On Windows systems, the MaxDB WebDBM service runs as System by default installation.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the MySQL MaxDB WebDBM Server Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  MySQL MaxDB WebDBM server buffer overflow

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO