Check Point Advisories

Cisco IP Phone SIP INVITE Message Denial of Service (CVE-2007-1542)

Check Point Reference: CPAI-2007-246
Date Published: 20 Dec 2009
Severity: Medium
Last Updated: 16 Oct 2017
Source:
Industry Reference:CVE-2007-1542
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description There exists a denial of service vulnerability in Cisco's IP phone models 7960 and 7940. The affected firmware cannot handle a specially crafted SIP INVITE message with an invalid IP address, causing the phone to reboot upon receiving the message. As a result, a remote user can cause a denial of service condition to IP phone service. In case of an attack, where a remote uesr sends a specially crafted SIP packet, the Cisco device running the SIP firmware will be forced to reload. The Cisco device will be unavailable for the several minutes it takes to reload. Repeated attacks could create a continuous denial of service condition.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Cisco IP Phone SIP INVITE Message Denial of Service protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  VoIP Enforcement Violation.
Attack Information:  Cisco IP Phone SIP INVITE Message Denial of Service

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO