Check Point Advisories

Squid Proxy Invalid HTTP Response Status Code Denial of Service (CVE-2009-2621)

Check Point Reference: CPAI-2009-227
Date Published: 23 Aug 2009
Severity: High
Last Updated: 23 Aug 2016
Industry Reference:CVE-2009-2621
Protection Provided by:

Security Gateway
R80, R77, R76, R75, R71, R70

Who is Vulnerable?
Vulnerability Description The Squid proxy server is a popular open source, Internet proxy and web caching application.A denial of service vulnerability has been reported in Squid proxy. The vulnerability is due to an error within the Squid proxy that fails to properly handle malformed HTTP responses. A remote attacker can exploit this flaw by specially crafting an HTTP response with a malformed status code and sending it to a vulnerable system. Successful exploitation may allow an attacker to create a denial of service condition on an affected server.

Protection Overview

This protection will detect and block specially crafted HTTP responses sent to the Squid proxy server.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Squid Proxy Invalid HTTP Response Status Code Denial of Service protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Proxy Server Enforcement.
Attack Information:  Squid Proxy invalid HTTP response status code denial of service