Check Point Advisories

Adobe Acrobat and Reader U3D CLODMeshDeclaration Memory Corruption (CVE-2009-2994)

Check Point Reference: CPAI-2011-592
Date Published: 3 Jan 2012
Severity: High
Last Updated:
Source: CVE-2009-2994
Protection Provided by:

Security Gateway
R75

Who is Vulnerable? Adobe Systems Adobe Acrobat 7.x prior to 7.1.4
Adobe Systems Adobe Acrobat 8.x prior to 8.1.7
Adobe Systems Adobe Acrobat 9.x prior to 9.2
Adobe Systems Adobe Reader 7.x prior to 7.1.4
Adobe Systems Adobe Reader 8.x prior to 8.1.7
Adobe Systems Adobe Reader 9.x prior to 9.2
Vulnerability Description A memory corruption vulnerability has been reported in Adobe Reader and Acrobat.
Vulnerability DetailsThe vulnerability is due to an index boundary error while handling specially crafted PDF files. A remote attacker may exploit this vulnerability by enticing unsuspecting users to open a malicious PDF document with an affected product. Successful exploitation could allow attacker to execute arbitrary code on the system.

Protection Overview

This protection will detect and block the transferring of malicious pdf files.

In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

Security Gateway R75 / R71 / R70

1. In the IPS tab, click Protections and find the Adobe Acrobat and Reader U3D CLODMeshDeclaration Memory Corruption protection using the Search tool and Edit the protection's settings.

2. Install policy on all modules.

SmartView Tracker will log the following entries:
Attack Name: Adobe Reader Violation
Attack Information: Adobe Acrobat and Reader U3D CLODMeshDeclaration memory corruption

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO