Check Point Advisories

Preemptive Protection against Microsoft Internet Explorer Invalid Pointer Reference Remote Code Execution Vulnerability (MS10-002)

Check Point Reference: CPAI-2010-012
Date Published: 17 Jan 2010
Severity: Critical
Last Updated: 1 Jan 2010
Source: Microsoft Security Advisory (979352)
Microsoft Security Bulletin MS10-002
Industry Reference:CVE-2010-0249
Protection Provided by:
Who is Vulnerable? Microsoft Windows 2000 SP4
Windows XP SP2
Windows XP SP3
Windows XP Professional x64 Edition SP2
Windows Server 2003 SP2
Windows Server 2003 x64 Edition SP2
Windows Server 2003 with SP2 (Itanium)
Windows Vista
Windows Vista SP1
Windows Vista SP2
Windows Vista x64 Edition
Windows Vista x64 Edition SP1
Windows Vista x64 Edition SP2
Windows Server 2008 for 32-bit Systems
Windows Server 2008 for 32-bit Systems SP2
Windows Server 2008 for x64-based Systems
Windows Server 2008 for x64-based Systems SP2
Windows Server 2008 (Itanium)
Windows Server 2008 (Itanium) SP2
Windows 7
Windows 7 for x64-based Systems
Windows Server 2008 R2 for x64-based Systems
Windows Server 2008 R2 (Itanium)
Vulnerability Description A use-after-free vulnerability exists in Microsoft Internet Explorer. An attacker could exploit this issue by constructing a specially crafted Web page that when viewed by a user, could allow the attacker to execute arbitrary code remotely.
Update/Patch AvaliableApply patches:
Microsoft Security Bulletin MS10-002
Vulnerability DetailsThe vulnerability is due to an invalid pointer reference within Internet Explorer. By convincing a user to view a specially crafted web page, the attacker could execute arbitrary code on the user's system by accessing a pointer associated with a deleted object.

Protection Overview

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO