Check Point Advisories

Apple Safari Webkit CSS Charset Text Transformation Code Execution (CVE-2010-1770)

Check Point Reference: CPAI-2010-377
Date Published: 4 Aug 2010
Severity: Critical
Last Updated: 4 Jan 2017
Source: Apple HT4196
Industry Reference:CVE-2010-1770
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable? Apple Safari prior to 5.0
Vulnerability Description Safari is a web browsing application developed by Apple. Safari browsing functionality is built around the set of components called WebKit. WebKit is a development toolkit which allows third party developers to build applications that use Internet technologies such as HTML, HTTP, and others.A remote code execution vulnerability has been discovered in Apple Safari's WebKit. The vulnerability is due to the way the vulnerable application handles text objects via CSS. A remote attacker could exploit this issue by enticing the target user to open a maliciously crafted web page. Successful exploitation of this vulnerability could result in execution of arbitrary code within the security context of the current user.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Apple Safari Webkit CSS Charset Text Transformation Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Web Client Enforcement Violation.
Attack Information:  Apple Safari Webkit CSS charset text transformation code execution

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO