How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

Cisco AnyConnect VPN Client ActiveX Code Execution (CVE-2011-2039)

Check Point Reference: CPAI-2011-385
Date Published: 16 Aug 2011
Severity: Medium
Last Updated: 17 Feb 2016
Source:
Industry Reference:CVE-2011-2039
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description A remote code execution vulnerability has been reported in Cisco Anyconnect VPN Client. Annyconnect provides secured remote connection software solution for PCs and mobile devices. The vulnerability exists in the application VPN client's Activex control which aids in downloading and executing its VPN client.This is a remote code execution vulnerability. The vulnerability is due to the improper validation of the downloaded executable by the application. A remote attacker could trigger this vulnerability by enticing a user to open a malicious link on a computer with a vulnerable version of the software installed.Successful exploitation may allow an attacker to execute arbitrary code on an affected system, in the security context of the logged in user.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Cisco AnyConnect VPN Client ActiveX Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Cisco Protection Violation.
Attack Information:  Cisco AnyConnect VPN Client ActiveX code execution