Check Point Advisories

Apple Safari WebKit innerHTML use-after-free Memory Corruption (CVE-2011-0221)

Check Point Reference: CPAI-2011-440
Date Published: 27 Sep 2011
Severity: Critical
Last Updated: 22 Dec 2016
Source:
Industry Reference:CVE-2011-0221
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description A code execution vulnerability has been reported in Apple Safari. The vulnerability is due to an error in the application while trying to free parent objects. A remote attacker may exploit this vulnerability by enticing affected users to open a specially crafted web-page. Successful exploitation would allow an attacker to execute arbitrary code on the system, in the security context of the logged on user. An unsuccessful attack may cause a memory corruption, which will abnormally terminate the application.

Protection Overview

This protection detects attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the Apple Safari WebKit innerHTML use-after-free Memory Corruption protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Web Client Enforcement Violation.
Attack Information:  Apple Safari WebKit innerHTML use-after-free Memory Corruption

This website uses cookies to ensure you get the best experience. More Info Got it, Thanks!