Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Nullsoft Winamp MIDI File Buffer Overflow

Check Point Reference: CPAI-2012-033
Date Published: 26 Mar 2012
Severity: Medium
Last Updated: 14 Feb 2016
Source:
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description A code execution vulnerability has been reported in Nullsoft Winamp. The vulnerability is due to a boundary error while handling malformed MIDI files. A remote attacker may exploit this issue by enticing a target user to open a specially crafted MIDI file with an affected version of Winamp. Successful exploitation could allow an attacker to execute arbitrary code on the target system. An unsuccessful attempt may cause the application to crash, resulting in a denial of service condition.

Protection Overview

This protection will detect and block the transferring of malicious MIDI files.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Nullsoft Winamp MIDI File Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Media Player Enforcement Violation.
Attack Information:  Nullsoft Winamp MIDI file buffer overflow

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO