How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

IBM Rational Rhapsody BBFlashBack.Recorder.dll Multiple Code Execution (CVE-2011-1388)

Check Point Reference: CPAI-2012-176
Date Published: 10 May 2012
Severity: Medium
Last Updated: 28 Feb 2016
Source:
Industry Reference:CVE-2011-1388
Protection Provided by:

Security Gateway
R80, R77, R76, R75

Who is Vulnerable?
Vulnerability Description Multiple code execution vulnerabilities have been reported in the BB FlashBack FBRecorder ActiveX control, a component of IBM Rational Rhapsody. The vulnerabilities are due to improper input validation within several methods. A remote attacker could exploit these vulnerabilities by enticing the target user to open a specially crafted web page. Successful exploitation would allow an attacker to overwrite arbitrary files in the file system as well as execute arbitrary code in the security context of the target user.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75

  1. In the IPS tab, click Protections and find the IBM Rational Rhapsody BBFlashBack.Recorder.dll Multiple Code Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  IBM Protection Violation.
Attack Information:  IBM Rational Rhapsody BBFlashBack.Recorder.dll multiple code execution