Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Adobe Photoshop Asset Elements Stack Buffer Overflow (CVE-2012-2052)

Check Point Reference: CPAI-2012-279
Date Published: 23 Jul 2012
Severity: High
Last Updated: 14 Feb 2016
Source:
Industry Reference:CVE-2012-2052
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description A buffer overflow vulnerability has been reported in Adobe Photoshop. The vulnerability is due to insufficient validation of certain elements. A remote attacker can exploit this vulnerability by enticing a victim to open a specially crafted DAE file using an affected version of Adobe Photoshop. Successful exploitation would allow an attacker to execute code on the target system.

Protection Overview

This protection will detect and block the transferring of malicious DAE files.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Adobe Photoshop Asset Elements Stack Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Adobe Products Violation.
Attack Information:  Adobe Photoshop Asset Elements stack buffer overflow

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO