Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Apple QuickTime Plugin SetLanguage Buffer Overflow (CVE-2012-0666)

Check Point Reference: CPAI-2012-376
Date Published: 14 Oct 2012
Severity: High
Last Updated: 18 Feb 2016
Source:
Industry Reference:CVE-2012-0666
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description A stack buffer overflow vulnerability has been reported in Apple QuickTime. The vulnerability is due to insufficient bounds checking when parsing parameters to a certain method inside the QuickTime plugin. A remote attacker can exploit this issue by enticing a target user to open a specially crafted web page. Successful exploitation would allow an attacker to execute arbitrary code on the target.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Apple QuickTime Plugin SetLanguage Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Apple QuickTime Protection Violation.
Attack Information:  Apple QuickTime plugin SetLanguage buffer overflow

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO