Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

Samba DCE RPC IDL Parser Out-of-bounds Array Access (CVE-2012-1182)

Check Point Reference: CPAI-2012-317
Date Published: 14 Oct 2012
Severity: Critical
Last Updated:
Source: CVE-2012-1182
Protection Provided by:

Security Gateway
R75

Who is Vulnerable? Samba Team Samba 3.4.x prior to 3.4.16
Samba Team Samba 3.5.x prior to 3.5.14
Samba Team Samba 3.6.x prior to 3.6.4
Vulnerability Description An out-of-bounds array access vulnerability has been reported in Samba.
Vulnerability DetailsThe vulnerability is due to an error in the RPC code generator, resulting in a heap memory corruption. A remote attacker can exploit this issue by sending specially crafted SMB traffic to an affected server. Successful exploitation could allow an attacker to execute arbitrary code in the security context of the logged-on user.

Protection Overview

This protection will detect and block malicious SMB traffic.

In order for the protection to be activated, update your product to the latest update. For information on how to update , go to SBP-2006-05, Protection tab and select the version of your choice.

Security Gateway R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Samba DCE RPC IDL Parser Out-of-bounds Array Access protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

SmartView Tracker will log the following entries:
Attack Name: MS-RPC over CIFS Enforcement Violation
Attack Information: Samba DCE RPC IDL Parser Out-of-bounds Array Access

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO