Check Point Advisories

VLC Media Player RTSP Plugin Stack Buffer Overflow (CVE-2013-6933)

Check Point Reference: CPAI-2014-0757
Date Published: 22 Jan 2014
Severity: Medium
Last Updated: 22 Jun 2020
Source:
Industry Reference:CVE-2013-6933
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable?
Vulnerability Description A stack buffer overflow exists in VideoLAN VLC Media Player. The vulnerability is due an error in VLC's embedded Live555 RTSP library, when handling RTSP requests. Incorrect handling of RTSP commands can result in a stack buffer overflow. A remote unauthenticated attacker could exploit this vulnerability by enticing the target user to connect to a malicious RTSP media stream or by opening a malicious playlist file. Successful exploitation could result in arbitrary code execution in the context of the application.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the VLC Media Player RTSP Plugin Stack Buffer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Media Player Enforcement Violation.
Attack Information:  VLC Media Player RTSP Plugin Stack Buffer Overflow

×
  Feedback
This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO