Check Point Advisories

Apache Struts ParametersInterceptor ClassLoader Security Bypass (CVE-2014-0094; CVE-2014-0112; CVE-2014-0113; CVE-2014-0114)

Check Point Reference: CPAI-2014-1480
Date Published: 25 Apr 2014
Severity: Critical
Last Updated: 4 Jun 2019
Source: Apache Struts S2-020
Industry Reference:CVE-2014-0094
CVE-2014-0112
CVE-2014-0113
CVE-2014-0114
Protection Provided by:

Security Gateway
R80, R77, R75, R71, R70

Who is Vulnerable? Apache Software Foundation Struts 2.0.0 - 2.3.16
Apache Software Foundation Struts 1.x
Vulnerability Description A security bypass vulnerability exists in Apache Struts. The vulnerability is due to inadequate validation of data processed by ParametersInterceptor allowing for manipulation of the ClassLoader. A remote attacker could exploit this vulnerability by providing a class parameter in a request.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Apache Struts ParametersInterceptor ClassLoader Security Bypass protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Apache Server Protection Violation.
Attack Information:  Apache Struts ParametersInterceptor ClassLoader Security Bypass

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO