How can I help you? Start Chat

US Phone: 1-866-488-6691
International Phone: +44-2036087492

  • E-Mail
  • Facebook
  • LinkedIn
  • Twitter

Check Point Advisories

Adobe Flash Player Buffer Overflow Arbitrary Code Execution (CVE-2014-0515)

Check Point Reference: CPAI-2014-1492
Date Published: 29 Apr 2014
Severity: Critical
Last Updated: 28 Feb 2017
Source: Adobe Security Bulletin APSB14-13
Industry Reference:CVE-2014-0515
Protection Provided by:

Security Gateway
R80, R77, R76, R75, R71, R70

Who is Vulnerable?
Adobe Flash Player 13.0.0.182 and earlier versions for Windows Adobe Flash Player 13.0.0.201 and earlier versions for Macintosh Adobe Flash Player 11.2.202.350 and earlier versions for Linux
Vulnerability Description An arbitrary code execution vulnerability has been reported in Adobe Flash Player. The vulnerability is due to a buffer overflow while handling specially crafted SWF files. A remote attacker can exploit this vulnerability to execute arbitrary files on the victim's computer.
Update/Patch AvaliableApply patches from: APSB14-13

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update.For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R76 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Adobe Flash Player Buffer Overflow Arbitrary Code Execution (CVE-2014-0515) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all modules.

This protection's log will contain the following information:

Attack Name:  Adobe Flash Protection Violation.
Attack Information:  Adobe Flash Player Buffer Overflow Arbitrary Code Execution (CVE-2014-0515)