Check Point Advisories

AlienVault OSSIM av-centerd Util.pm get_license Arbitrary Command Execution (CVE-2014-3805)

Check Point Reference: CPAI-2014-1722
Date Published: 20 Jul 2014
Severity: Critical
Last Updated: 16 Jan 2019
Source:
Industry Reference:CVE-2014-3805
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? AlienVault AlienVault 4.6.1 and prior
Vulnerability Description An arbitrary command execution vulnerability exists in AlienVault OSSIM. The vulnerability is due to a failure to safely sanitize user data while handling SOAP service requests via the get_license function of Util.pm. A remote unauthenticated attacker can exploit this vulnerability by sending crafted requests to the affected service. Successful exploitation could result in arbitrary command execution with root privileges.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the AlienVault OSSIM av-centerd Util.pm get_license Arbitrary Command Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Security Products Enforcement Violation.
Attack Information:  AlienVault OSSIM av-centerd Util.pm get_license Arbitrary Command Execution

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO