|Check Point Reference:||CPAI-2014-1850|
|Date Published:||1 Oct 2014|
|Last Updated:||21 Oct 2018|
|Protection Provided by:||
|Who is Vulnerable?|| Trustwave: SpiderLabs ModSecurity prior to 2.7.6 |
Apache2 component in PHP before 5.6.38, 7.0.x before 7.0.32, 7.1.x before 7.1.22, and 7.2.x before 7.2.10
|Vulnerability Description||A cross-site scripting vulnerability exists in Apache2 PHP component. The vulnerability is due to improper comparison of the user supplied input of the HTTP Transfer-encoding header field. A remote, unauthenticated attacker could exploit this vulnerability by sending a crafted HTTP request to send malicious payloads and bypass firewall filter policies. Successful exploitation of this vulnerability would allow remote attackers to inject an arbitrary web script into the affected system.|
This protection will detect and block attempts to exploit this vulnerability.
In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.
This protection's log will contain the following information:
Attack Name: Web Server Enforcement Violation.
Attack Information: Apache2 PHP Component Chunked Transfer Encoding Policy Bypass