Check Point Advisories

Adobe Flash Player Memory Corruption (APSB15-04: CVE-2015-0318)

Check Point Reference: CPAI-2015-0168
Date Published: 17 Feb 2015
Severity: Critical
Last Updated: 23 Aug 2018
Source: Adobe APSB15-04
Industry Reference:CVE-2015-0318
Protection Provided by:

Security Gateway
R80, R77, R75, R71, R70

Who is Vulnerable? Adobe Flash Player 16.0.0.296 and earlier versions
Adobe Flash Player 13.0.0.264 and earlier 13.x versions
Adobe Flash Player 11.2.202.440 and earlier 11.x versions
Vulnerability Description A memory corruption vulnerability has been reported in Adobe Flash Player. The vulnerability is due to an error in Adobe Flash Player while parsing a specially crafted SWF file. A remote attacker can exploit this issue by enticing a victim to open a specially crafted SWF file.
Update/Patch AvaliableApply patches from: APSB15-04

Protection Overview

This protection will detect and block the transferring of malformed SWF files.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the Adobe Flash Player Memory Corruption (APSB15-04: CVE-2015-0318) protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Adobe Flash Protection Violation.
Attack Information:  Adobe Flash Player Memory Corruption (APSB15-04: CVE-2015-0318)

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO