Learn more on how to stay protected from the latest Ransomware Pandemic
Check Point Advisories

OpenSSL TLS Export Cipher Suite Downgrade (CVE-2015-0204; CVE-2015-1637)

Check Point Reference: CPAI-2015-0223
Date Published: 4 Mar 2015
Severity: High
Last Updated: 3 Dec 2017
Source: OpenSSL
Industry Reference:CVE-2015-0204
Protection Provided by:

Security Gateway
R80, R77, R75, R71, R70

Who is Vulnerable? OpenSSL before 0.9.8zd, 1.0.0 before 1.0.0p, and 1.0.1 before 1.0.1k
Vulnerability Description A vulnerability has been detected in the way OpenSSL handles TLS handshakes that use weak, legacy cipher suites. An attacker might leverage this vulnerability to intercept secure communications.

Protection Overview

This protection may be used to prevent attacks exploiting the FREAK vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75 / R71 / R70

  1. In the IPS tab, click Protections and find the OpenSSL TLS Export Cipher Suite Downgrade protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  SSL Enforcement Violation.
Attack Information:  OpenSSL TLS Export Cipher Suite Downgrade

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO