Check Point Advisories

PHP Group PHP ZIP Integer Overflow (CVE-2015-2331)

Check Point Reference: CPAI-2015-0471
Date Published: 14 Apr 2015
Severity: High
Last Updated: 29 Aug 2018
Source: PHP
Industry Reference:CVE-2015-2331
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? PHP Group PHP 5.4.x prior to 5.4.39
PHP Group PHP 5.5.x prior to 5.5.23
PHP Group PHP 5.6.x prior to 5.6.7
Vulnerability Description A heap buffer overflow vulnerability exists in PHP. The vulnerability is due to an integer overflow in the libzip component of PHP. A remote attacker can exploit this vulnerability by sending a crafted ZIP archive to a web application running a vulnerable version of PHP. A successful attack can result in remote code execution under the context of the service running PHP.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the PHP Group PHP ZIP Integer Overflow protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  PHP Group PHP ZIP Integer Overflow

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO