Check Point Advisories

Apple CUPS cupsd Privilege Escalation (CVE-2015-1158)

Check Point Reference: CPAI-2015-0798
Date Published: 5 Jul 2015
Severity: Critical
Last Updated: 5 Dec 2018
Source: Apple Computer
Industry Reference:CVE-2015-1158
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? Apple Computer Common UNIX Printing System (CUPS) prior to 2.0.3
Vulnerability Description An elevation-of-privilege vulnerability has been reported in the Apple CUPS. The vulnerability is due to improper processing of print-job or create-job requests sent to cupsd. A remote, unauthenticated attacker can send a specially crafted localized strings to cause the 'admin/conf' and 'admin' access control lists to fail. Successful exploitation could lead to elevation of privileges on the affected system, giving the attacker the ability to execute arbitrary code with root privileges.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Apple CUPS cupsd Privilege Escalation protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Application Servers Protection Violation.
Attack Information:  Apple CUPS cupsd Privilege Escalation

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO