Check Point Advisories

Elasticsearch Sandbox Escape Command Execution (CVE-2015-1427)

Check Point Reference: CPAI-2015-1224
Date Published: 19 Oct 2015
Severity: High
Last Updated: 25 Jul 2019
Source:
Industry Reference:CVE-2015-1427
Protection Provided by:

Security Gateway
R80, R77, R75

Who is Vulnerable? elasticsearch:1.3.7 and previous versions
elasticsearch:1.4.0:beta1
elasticsearch:1.4.0
elasticsearch:1.4.1
elasticsearch:1.4.2
Vulnerability Description A remote command execution (RCE) vulnerability exists in the Groovy scripting engine in Elasticsearch. The vulnerability is due to certain scripts bypassing the sandbox protection mechanism. A remote attacker can exploit this weakness to execute arbitrary code via a specially crafted request.

Protection Overview

This protection will detect and block attempts to exploit this vulnerability.

In order for the protection to be activated, update your Security Gateway product to the latest IPS update. For information on how to update IPS, go to SBP-2006-05, click on Protection tab and select the version of your choice.

Security Gateway R80 / R77 / R75

  1. In the IPS tab, click Protections and find the Elasticsearch Sandbox Escape Command Execution protection using the Search tool and Edit the protection's settings.
  2. Install policy on all Security Gateways.

This protection's log will contain the following information:

Attack Name:  Web Server Enforcement Violation.
Attack Information:  Elasticsearch Sandbox Escape Command Execution

This website uses cookies to ensure you get the best experience. Got it, Thanks! MORE INFO